[Bug 2408] Unsupported VGA register when LocoScript (DOS program) run under Wine

Wine Bugs wine-bugs at winehq.org
Mon Oct 9 23:40:08 CDT 2006


------- Additional Comments From emmfamlame-001 at yahoo.com.br  2006-09-10 23:40 -------
Wine  Doesn't run a DOS program  (called LeCx.exe)
created with the  Clipper'85  compiler running on a  Win XT  in this machine
( Clipper creates .exe files from the Dbase .prg files ).

Wine reports:

Warning: unprotecting memory to allow real-mode calls.
         NULL pointer accesses will no longer be caught.
fixme:ddraw:VGA_ioport_out Unsupported VGA register: 0x03d8 (value 0x29)
wine: Unhandled page fault on read access to 0x00002d58 at address 0x7bee1ce7
(thread 000c), starting debugger...

I'm running  Ubuntu Breezy (5.10)  in  live-CD mode,
the Wine version is 1.9.19

Also, I tryed using the wineconsole,
but it did the same error.

If it may help, 
I tried to run the DOS program LeCx.exe into the DOSEMU ,  and it worked ok 
(but much slower than under win xp, at least at the outputing caracters to the

I have attached the  LeCx.exe  and  the  Debug messages fom the Wine.

I hope to be helping,
congratulations to all of you,

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

More information about the wine-bugs mailing list