Make RECT === RECTL, fix compile warnings, use uniform format

Dimitrie O. Paun dpaun at rogers.com
Tue Dec 31 00:52:45 CST 2002


On December 31, 2002 03:03 am, Dan Kegel wrote:
> +#define debugrect(r) __debugrect((r), &__wine_dprintf_ptr)

Yeah, that can work too, but it does increase stack usage by
quite a bit. But if we are to do this for RECTs only we don't
need as much space anyway... Nevertheless, it's an alternative
solution, and it does not require exporting more stuff out of
ntdll. Let's wait for Alexandre's take on it. :)

> BTW debugrect() isn't a great name... can't think of a snappy replacement
> offhand, though.

True, but it has the following nice caracteristics:
  -- uses the debug prefix
  -- easy to remember if we have the naming convention:
      debug<struct-name-to-lower-case>
  -- it is short

Would be nice to have such std functions for a bunch of structures,
like I did in listview.c. They are extremely handy, and can save you
quite a bit of time when you want to dump stuff out. And if more of
these become standard, a simple naming convention like this one pays.

Feel free to suggest something else though! :)

-- 
Dimi.




More information about the wine-devel mailing list