Registry problem

steve.lustbader at philips.com steve.lustbader at philips.com
Wed Oct 9 11:05:15 CDT 2002


I tried the cvs source from October 7, and the problem doesn't occur
(although winamp does crash with an unimplemented MSVCRT function
when I try to run it).



                                                                                                                                                                                                                           
                      steve.lustbader+FromInterNet@                                                                                                                                                                        
                      philips.com                               To:  Sylvain Petreolle <spetreolle at yahoo.fr>                                                                                                               
                      Sent by:                                  cc:  wine-devel at winehq.com                                                                                                                                 
                      wine-devel-admin at winehq.com                (bcc: Steve Lustbader/ANR/MS/PHILIPS)                                                                                                                     
                                                                Subject:   Re: Registry problem                                                                                                                            
                                                                                                                                                                                                                           
                      10/09/2002 10:42 AM                       Classification:                                                                                                                                            
                                                                                                                                                                                                                           
                                                                                                                                                                                                                           




I'm using the latest cvs source (I update every day).  I tried
using a native advapi32 (from WinXP, which is all I have access
to), but that just resulted in lots of other problems (unimplemented
functions in ntdll.dll, etc.

When I try to run WinAmp, it exits immediately with that same error.
It doesn't run at all, unlike the installer, which runs but then ends
with the error (probably when it tries to run winamp itself).

Is it possible that sound isn't set up properly on my system?  I don't
really need sound on it, so I haven't played around with it too much.
It's just the normal Redhat 7.2 install, with whatever sound settings
it picked.  I can listen to mp3's with xmms, though.

-Steve




                      Sylvain
                      Petreolle                    To:  Steve Lustbader/ANR/MS/PHILIPS at AMEC
                      <spetreolle at yaho              wine-devel at winehq.com
                      o.fr>                        cc:
                                                   Subject:   Re: Registry problem
                      10/09/2002 02:18
                      AM                           Classification:






What version of wine did you use ?
With CVS of Oct 08, I install without problem.

 --- steve.lustbader at philips.com a écrit : > I started having a problem
with today's source that appears
> to be either registry or sound related.  When I tried to
> install Winamp (v 2.81 lite) in wine, I get this error:
>
> wine client error:8091280: sendmsg: Bad file descriptor
>
> Output from +reg,+relay ends with
>
> 08091280:Call
>
ntdll.NtQueryValueKey(00000048,40124878,00000002,406e2acc,00000100,406e2ac0)
> ret=40977acc
> trace:reg:NtQueryValueKey (0x48,L"WaveMapper",2,0x406e2acc,256)
> wine client error:8091280: sendmsg: Bad file descriptor
>
> (the last 100 lines of the output can be seen at
> http://www.lustbader.net/winamp.txt)
>
> I tried getting rid of my ~/fake_c and ~/.wine directories
> and running wineinstall again, but that didn't help.
>
> -Steve
>
>

___________________________________________________________
Do You Yahoo!? -- Une adresse @yahoo.fr gratuite et en français !
Yahoo! Mail : http://fr.mail.yahoo.com












More information about the wine-devel mailing list