wine/programs/regedit regproc.h regproc.c rege ...

Dustin Navea speeddymon at yahoo.com
Thu Aug 14 14:37:15 CDT 2003


--- Vincent Béron <vberon at mecano.gme.usherb.ca> wrote:
> Le mer 06/08/2003 à 23:10, Alexandre Julliard a écrit :
> > ChangeSet ID:	8934
> > CVSROOT:	/home/winehq/opt/cvs-commit
> > Module name:	wine
> > Changes by:	julliard at wine.codeweavers.com	2003/08/06 22:10:13
> > 
> > Modified files:
> > 	programs/regedit: regproc.h regproc.c regedit.c Makefile.in 
> > 	                  .cvsignore 
> > Added files:
> > 	programs/regedit: treeview.c rsrc.rc resource.rc resource.h 
> > 	                  main.h main.c listview.c framewnd.c childwnd.c 
> > 	                  about.c En.rc 
> > 
> > Log message:
> > 	Robert Dickenson <robd at reactos.org>
> > 	Steven Edwards <Steven_Ed4153 at yahoo.com>
> > 	Mike McCormack <mike at codeweavers.com>
> > 	Implemented GUI for regedit.
> > 
> > Patch:
> http://cvs.winehq.com/patch.py?root=/home/winehq/opt/cvs-commit&id=8934
> 
> regedit.c:
> @@ -153,10 +154,13 @@
>      }
>  
>      if (action == ACTION_UNDEF)
> -    {
> -        action = ACTION_ADD;
> +        return FALSE;
> +
> +    return PerformRegAction(action, s);
>      }
> 
> 
> This seems to have broken commandline only regedit, for the ACTION_ADD
> case (used in wineinstall et al.).
> 
> The included patch should fix it (building in progress).
> 
> Vincent
> > Index: wine/programs/regedit/regedit.c
> ===================================================================
> RCS file: /home/wine/wine/programs/regedit/regedit.c,v
> retrieving revision 1.6
> diff -u -r1.6 regedit.c
> --- wine/programs/regedit/regedit.c	7 Aug 2003 03:10:13 -0000	1.6
> +++ wine/programs/regedit/regedit.c	14 Aug 2003 01:01:38 -0000
> @@ -153,6 +153,9 @@
>          }
>      }
>  
> +    if (*s && action == ACTION_UNDEF)
> +        action = ACTION_ADD;
> +
>      if (action == ACTION_UNDEF)
>          return FALSE;
>  
> 

<IMHO> I think this would be a little cleaner (or at least easier to read):

    if (*s && action == ACTION_UNDEF)
        action = ACTION_ADD;
    else if (action == ACTION_UNDEF)
        return FALSE;

that or 

    if (action == ACTION_UNDEF)
    {
        if (*s)
            action = ACTION_ADD;
        return FALSE;
    }

except that I cant make diffs..  sorry about the nitpicking but it just didnt
look right and would have been bloat </IMHO>

=====
--
Dustin Navea

Minor Contributor, http://www.winehq.com
Bugzilla Janitor, http://bugs.winehq.com
Network Admin, irc://irc.blynk.net (down)

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com



More information about the wine-devel mailing list