Make VIRTUAL_SetFaultHandler an internal function

Dimitrie O. Paun dpaun at rogers.com
Sun Apr 17 10:47:35 CDT 2005


On Mon, Apr 18, 2005 at 12:29:07AM +0900, Dmitry Timoshkov wrote:
> "Dimitrie O. Paun" <dpaun at rogers.com> wrote:
> 
> > +struct mem_area
> > +{
> > +    struct list   entry;       /* Entry in global mem area list */
> > +    const void   *base;        /* Base address */
> > +    UINT          size;        /* Size in bytes */
> > +    void         *data;        /* Data associated with this area */
> > +};
> 
> One more nitpick: it's better to change the size type to SIZE_T from UINT
> to allow 64-bit size memory allocations on (future) Win64.

Yeah, and on second thought even this "mem_area" is too general because
they are build specifically for DIBs. I should rename them dib_area,
and instead of "void         *data", I should have "X_PHYSBITMAP *physBitmap".

But I'd like to hear from AJ is this is OK first :)

-- 
Dimi.



More information about the wine-devel mailing list