Code cleanup: SHFileOperationW
mike at navi.cx
Thu Jan 13 10:41:50 CST 2005
On Thu, 13 Jan 2005 15:12:17 +0100, Joris Huizer wrote:
> I took out a part of the function SHFileOperationW and put it in a new
> function - please give any comments: is this the way to make this
> function more readable you want it? what is a better way of calling such
> a function?
Yes this looks good but for internal functions IMHO it's best to use
GNU style naming, eg:
static int file_operation_delete(...)
That way it's (A) obvious what's internal and exported and (B) mixtures of
GNU style and Win32 style in the same name are ugly :)
Remember internal functions don't need WINAPI linkage.
Finally be careful with diff, you included some Interlocked* fixes in
More information about the wine-devel