On Fri, Jan 14, 2005 at 11:32:56AM +0100, Paul Vriens wrote: > HDF_LEFT is also 0, so should we get rid of the first check, and only > check for LVCFMT_RIGHT and LVCFMT_CENTER? Yes, you could remove it, but it will save nothing and will make the code harder to read. gcc most like optimizes it out anyway. Let's leave it in. -- Dimi.