cmd: Use NUL/0 instead of 0x00

Frédéric Delanoy frederic.delanoy at gmail.com
Tue Sep 13 10:37:42 CDT 2011


2011/9/13 Alexandre Julliard <julliard at winehq.org>:
> Frédéric Delanoy <frederic.delanoy at gmail.com> writes:
>
>> @@ -374,7 +374,7 @@ void WCMD_HandleTildaModifiers(WCHAR **start, const WCHAR *forVariable,
>>       points to the variable just after the modifiers. Process modifiers
>>       in a specific order, remembering there could be duplicates           */
>>    modifierLen = lastModifier - firstModifier;
>> -  finaloutput[0] = 0x00;
>> +  finaloutput[0] = '\0';
>
> It's mostly a matter of taste, but I don't think '\0' is better than
> 0x00, it's just another complicated way of writing 0.

Well IMHO '\0' clearly indicates a char value, while 0 could be an
integer (not in this obvioius example of course).
This way you've a visual indicator/differentiator with nearby integer
values assignments like "foo_integer_var = 0", and this could make the
code more readable IMO



More information about the wine-devel mailing list