(try 3)winex11.drv: Strip the _L or _R from X11DRV_GetKeyNameText when approperate

Dmitry Timoshkov dmitry at baikal.ru
Fri Jan 20 09:17:03 CST 2012


Aric Stewart <aric at codeweavers.com> wrote:

> +            char* idx = strrchr(name,'_');
> +            if (idx)
> +            {
> +                if (strcasecmp(idx,"_r")==0 || strcasecmp(idx,"_l")==0)
> +                {
> +                    INT rc = 0;
> +                    TRACE("found scan=%04x keyc=%u keysym=%04x modified_string=%s\n",
> +                           scanCode, keyc, (int)keys, debugstr_an(name,idx-name));
> +                    if (lpBuffer && nSize)
> +                    {
> +                        rc = MultiByteToWideChar(CP_UNIXCP, 0, name, idx-name, lpBuffer, nSize);

Using consistent spacing and avoiding not necessary casts would improve
the readability a bit.

-- 
Dmitry.



More information about the wine-devel mailing list