tests: Avoid duplicating debugstr_guid()

Frédéric Delanoy frederic.delanoy at gmail.com
Thu Jan 16 11:49:57 CST 2014


On Thu, Jan 16, 2014 at 1:02 PM, Jacek Caban <jacek at codeweavers.com> wrote:
> Hi Frédéric,
>
> On 01/15/14 23:53, Frédéric Delanoy wrote:
>> diff --git a/include/wine/test.h b/include/wine/test.h
>> index 373fe76..d7ce8c1 100644
>> --- a/include/wine/test.h
>> +++ b/include/wine/test.h
>> @@ -65,6 +65,7 @@ extern void winetest_add_failures( LONG new_failures );
>>  extern void winetest_wait_child_process( HANDLE process );
>>
>>  extern const char *wine_dbgstr_wn( const WCHAR *str, int n );
>> +extern const char *debugstr_guid( const GUID *guid );
>
> You probably want to follow existing test.h convention and call it
> wine_dbgstr_guid. This has a bonus advantage that you may split the
> patch for function introduction and per-dll replace.

I just didn't rename it to keep the patch minimal by avoiding renaming
every call but OK.
Do you think I should split that patch in order to have 1! patch per
DLL? Or is that overkill?

> Thanks,
> Jacek



-- 
Frédéric Delanoy



More information about the wine-devel mailing list