[AppDB] browse apps: Add support for only showing downloadable apps

Alexander Nicolaysen Sørnes alex at thehandofagony.com
Sun Jun 15 10:57:07 CDT 2008


Options are handled by the caller instead of the filter manager, because they 
for instance often contain extra dependencies on which tables to select .

You're right, though; getFilter() was a bad name altogether; I've renamed it 
getExpression() to clarify that it returns an SQL expression representing the 
current filter.

This version includes the name change and a few comments.

På Søndag 15 juni 2008 , 17:41:38 skrev Chris Morgan:
> Why return an empty string here? We should have some documentation on
> this getFilter() function and some documentation on why we would be
> returning '' in the case of a boolean filter option.
>
> @@ -74,6 +74,9 @@ class Filter
>
>      public function getFilter()
>      {
> +        if($this->iType == FILTER_OPTION_BOOL)
> +            return '';
> +
>
>
> Chris
>
>
>
>
>
>
> On Sun, Jun 15, 2008 at 6:00 AM, Alexander Nicolaysen Sørnes
>
> <alex at thehandofagony.com> wrote:
> > Now we can remove the 'downloadable apps' page, which will be done by the
> > next patch.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-browse-apps-Add-support-for-only-showing-downloadab.patch
Type: text/x-diff
Size: 13453 bytes
Desc: not available
Url : http://www.winehq.org/pipermail/wine-patches/attachments/20080615/a43e8760/attachment.patch 


More information about the wine-patches mailing list