Maple, MathCad, Greek letters (was: Greek letters)

Victor Shirokov vshirokov at
Thu Apr 19 12:02:02 CDT 2001

Jonathan Kress wrote:
> Hi.
> I was having trouble getting Greek letters and mathematical
> symbols in maple under wine, and a search turned up a few messages
> suggesting others have the same problem.  In particular,
> Thomas Koenig wrote...
> > I wrote:
> >
> > >I have tried several applications which use Greek letters, such as
> > >Maple V R5 and MathCad 2000, and so far I haven't had any luck in
> > >getting them to be displayed (nothing is displayed instead). Any
> > >ideas?
> > >
> > >Configuration: XFree86 4.0.2, Debian woody, Linux 2.2.19.
> >
> > ... and Wine 2001-03-26, I forgot to add.
> >
> > Is this a well-known problem, from the silence so far?
> I'm using Debian potato and an apt-get'able package of 2001-03-26
> from
> After much digging around I have a fix to offer.  Well, it's not
> the ultimate solution, but it'll do me for now.  Maybe it'll work
> for others too.
> It's seems that windows applications either already know
> about the adobe symbol font encodings, or some translation is
> done before I could catch it in the --debugmsg log files.  Wine
> picks the correct unicode -> codepage table (from the source
> unicode/c_042.c) and applies it to characters already in adobe's
> symbol format.
> I've had success with two work arounds.
> One involves simply editting the font.dir files.  I found wine was
> using the files /usr/lib/X11/fonts/75dpi/symb*.pcf.gz for the symbol font.
> So I editted the fonts.dir file in this directory and changed all
> instances of -adobe-fontspecific to -iso8859-1
> ie
> symb12.pcf.gz -adobe-symbol-medium-r-normal--12-120-75-75-p-74-adobe-fontspecific
> becomes
> symb12.pcf.gz -adobe-symbol-medium-r-normal--12-120-75-75-p-74-iso8859-1
> and the rest...
> Then do an 'xset fp rehash' and the symbol font should be fine under wine.
> I've tried charmap.exe, fontmap.exe and wordpad.exe as well as wmaple.exe
> and they seem to work too.   This might cause havoc with X applications
> that want to use the symbol font though.
> Alternatively, I also had success changing unicode/c_042.c and
> recompiling.  Replacing the first block of 256 entries in uni2cp_low with
> the same block from unicode/c_28591.c, recompiling
> and replacing the one in /usr/lib seems to work.  With this approach, no
> change to the fonts.dir files is necessary.
> There may be other windows apps that use unicode to pick characters
> from the symbol font, and so this might be more of a maple than a
> wine problem.  I'm sure others understand this better than I.
> Anyway, I hope this is helpful.
> Jonathan
> PS I'm not subscribed to the wine-users list, so reply to my email
> address if you want to contact me.

All you needed was just to add the aliases to fonts.alias file like that

<other part>-adobe-fontspecific  <other part of font name>-iso8859-1

That is the decision!
Good luck!


More information about the wine-users mailing list