[Wine] Re: Wine and MS Access problem

Daniel Skorka skorka at gmx.net
Mon Mar 19 00:49:16 CDT 2007

Robert McLean <robert.mclean1 at sympatico.ca> wrote:
> I didnt understand why D: was mapped to /mnt/windows/C, or why E: was
> mapped to D, but i thought maybe the machine knows better than me, so I
> tried running wine with those settings.  But I got error message about
> not finding the program file on D.  Obviously since it is looking for D
> files on C.

Because there is no reason for wine to do otherwise. You can call the
mountpoints whatever you like, wine doesn't give a damn.

> So I try wine with my spice program scad3.exe, and with msaccess.
> With scad3 it launches, and mostly works.  When I hit the open file
> command I can browse a directory tree as one  would expect, and I can
> see files on D, and I can see files on C where they belong.  So it is
> seeing C drive from that point of view.  But when I try to do a circuit
> simulation, it is necessary for the program to look up "include" files,
> and these are on my C drive.  It doesnt find them.    It does find
> them, and the program works perfectly, when I have the Wine
> configuration set to C:  /mnt/windows/C

Solution: Copy files from /mnt/windows/C to the respective place under

>> Well, you were wrong. What you never should do is something like
>> $ wine /path/to/app.exe
> But I didnt do anything like that.  Perhaps the term mapping is
> incorrect.  All I did was go into wine config and set C: to
> /mnt/windows/C  , in other words set it to where it is actually mounted
> in linux
>> Instead, do
>> $ cd /path/to && wine app.exe
>> This solves most file not found problems. If that doesn't help, well
>> have to keep looking.
> OK, what I did was try to figure out where my wine executables are.
> Being new to linux, I am not sure if I have found them.  I see in
> /usr/lib/wine a lot of files with extensions .dll.so and .exe.so  From
> what I can gather .so means they are shared files.  The file types
> given in the File Browser doesnt actually call any of the files I can
> find applications, or executables or any term like that.  So have I
> found the right folder ?
> In any case I tried cd /use/lib/wine, got to the folder in question,
> and then ran wine, but the results were the same.

*sigh* You are confusing a lot of things here.
/path/to/app.exe refers to any windows program you have installed, _not_
to the wine installation. It also isn't related to drive mapping.


More information about the wine-users mailing list