[Wine] How do you fix that gdi32.dll error?

Samuel Pinches pinchies at gmail.com
Tue Mar 3 06:38:18 CST 2009

Hi, I'm Sam, I'm new to the mail list (and mailing lists in general) -  
sorry for any basic mistakes I make!
I basically a noob when it comes to compiling things, and a beginner  
at the command line. I think I messed a couple of things up, and was  
wondering if anyone knew how I could fix any of them.
The story so far:
I had one of the old Darwine builds working ok with a couple apps, but  
when I couldn't get flash or shockwave versions working (it would  
crash firefox.exe) , I searched around for newer builds. I tried  
macports (through porticus gui) and installed wine from there, then  
tried to uninstall it as I discovered it had no application that I  
could run, and that exe's couldn't be directly launched from the  
finder like darwine. Well, it failed to uninstall all the dependancies  
it had installed so i uninstalled all of them one by one.
I then deleted all wine elements I could find, including the .plist  
and the .wine directory.
I tried the .pkg installer for darwine 1.1.14 and chose to install all  
the font/text tools with it, but now I get the dreaded gdi32.dll  
message and have no clue how to fix it. I have downloaded the latest  
Xquartz but haven't installed it yet.

Is there a way I can fix the mess I made? Should I re-install X11 from  
the restore DVD first?
(Many!) Thanks,

More information about the wine-users mailing list