[Wine] Civ4 current version could not be determined

calcipher wineforum-user at winehq.org
Tue Mar 23 21:36:38 CDT 2010

I am attempting to install Civlization 4 under Wine in Ubuntu 9.10x64.  Now, about a week ago, I started installing Civ and had no problems but, for various reasons, had to uninstall it, but today I decided to try again.  When I run the setup.exe file the install shield fires up and I get an error message "The current version of the application could not be determined" after which the install aborts.
Now, I figured my problem was due to having once installed Civ, so I deleted my .wine folder.  Trying the install again gets the same error.  I decided to purge my current wine install and reinstall wine - same problem.  Next, I removed the Wine for Ubuntu team ppa, purged wine (install says 1.2, but wine --version reports 1.1.something), installed the 9.10 standard version... Still no luck.  Finally, I purged wine again, readded the ppa, installed wine 1.2 (again, claims to be 1.2 but reports 1.1), and tried the install again.  Failure, same error.
I think the problem has to do with installshiled, but I can't figure out why things won't work.  Any ideas?

More information about the wine-users mailing list