[Wine] Problem: enable multiuser wine

MirkwoodTheGreat wineforum-user at winehq.org
Thu Apr 12 13:39:45 CDT 2012

Hallo, folks,

in openSuSE 12.1, I installed wine from the Wine CVS Builds repository. I knew it would work perfectly as of my experience on 11.4. In the end, it does! BUT I tried a different thing - it does run the programme, but only for one user!

To get the programmes installed under WINE working for every user (one single laptop, different accounts), I tried the following recommendation (http://www.linux-club.de/viewtopic.php?f=16&t=58822#p339026). Each user is supposed to have his own environment and home-directory, but all of them are supposed to share drive_c and the installed programmes.

1. set up wine for one user ('wineuser' who is supposed to act as wine-administrator) and created a group 'wineuser'
2. created directory /opt/winec
3. moved directory tree from /home/wineuser/.wine to /opt/winec/.wine (of course, one can savely choose /opt/wine; and of course, one can create a separate partition for that folder).
4. set a link from /home/wineuser/.wine to /opt/winec

ln -s /opt/winec/.wine ~/.wine

 Set permissions to owner (wineuser) rwx, group (wineuser) r-x, others r-x

for each $USER
5. built each $USER's .wine-environment with the fake drive_c by logging into each $USER's GUI and running 'winecfg', but didn't install any software.
6. moved each $USER's ~/.wine/drive_c/users/$USER (except 'wineuser's') to /opt/winec/.wine/drive_c/users/$USER. Ownership remained (set permissions via GUI, an abler man should have used chmod). So each $USER is supposed to have his individual profile on drive_c ("C:").
7. a. deleted each $USER's ~/.wine/drive_c to replace it by a soft link to /opt/winec/.wine/drive_c (command: see step (4.))
b. deleted each $USER's ~/.wine/system.reg to replace it by a soft link to /opt/winec/.wine/system.reg (command: see step (4.))
c. left ~/.wine/user.reg for individual registry entries.
d. didn't perform the following: "if useful or necessary, initialise by a copy of /opt/winec/user.reg".
8. left any files or folders in ~/.wine untouched.

The author of the above guide argues that there might be problems with system.reg.

9. installed MS Office 2007 SP3. Word processor etc run fine on 'wineuser's' account, but don't start on any other account.

Is there a way?

Thanks for any help!!!

Notebook: Lenovo G530 4446-25G --- Dualboot: (1) Windows 7 32bit; (2) openSUSE 12.1 KDE 32bit - wine 1.5.1 (installed from community repository http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_12.1/ )

More information about the wine-users mailing list