[Bug 2885] Max Payne fails to start

Wine Bugs wine-bugs at winehq.org
Sat Nov 12 14:46:00 CST 2005


------- Additional Comments From zarquon at t-online.de  2005-12-11 14:46 -------
------- Additional Comments From saulius.krasuckas at elst.vtu.lt  2005-12-11 06:59
> | Still, I did
> | 
> | > $ mkdir ~/BACKUPS
> | > $ mv ~/.wine ~/BACKUPS 
> | > $ wineprefixcreate
> | 
> | today and the MaxPayne demo failed with the same error. So no luck there,
> | and I'm back to my old .wine again.
> Hmmmm, did you installed MaxPayne into fresh wine system (empty C: drive)? 
> Because if you haven't, that hardly can be counted as a full check using clean
> system. :-P

No, I haven't. And I don't see any point whatsoever in doing that, because
considering that all the variations I've already tried so far haven't changed
the error nor the logfile in the least it should be plain to anyone that the
problem lies elsewhere. I'm a software developer myself, I do know how to
interpret and hunt down errors; continuing to assume the problem is my
installation at this point is way beyond clutching at straws.

> | Done. Unfortunately the OpenGL driver isn't particularily talkative either,
> | but maybe those two extra lines give you further insight
> You're right - I forgot OpenGL.DLLs process_attach() and process_detach()
> routines are very silent. (I've patched them once in my tree to talk a bit more
> stuff, but that might not sufficient in your case)

Well, if you can tell me where to output stuff or send me a diff that
patches the driver I can give it a go. Best would be committing the
changes to CVS for potential future problems.

> | What I'd really like to know ATM: what kind of graphics cards and driver
> | versions do people use for whom the current system works?
> # lspci | grep VGA
> # cat /var/log/Xorg.0.log | grep -i nvidia.*x.*driver
> | (II) NVIDIA X Driver  1.0-7676  Fri Jul 29 13:01:02 PDT 2005

Hmm... you're running Xorg, I'm still using XF86 4.3, apart from that I
don't see any noteworthy difference. My kernel driver is a little older
(1.0-7167), but since I've had the exact same behaviour at least since
6*-versions (maybe 5*-versions, I can't say for sure when I first tried),
I really don't think that's it.

> Native nVidia drivers are installed on top over Fedoras Mesa-libGL and
> Mesa-libGLU packages:
> # rpm -qa | gr mesa
> | xorg-x11-Mesa-libGL-6.8.2-31
> | xorg-x11-Mesa-libGLU-6.8.2-37.FC4.49.2

Mesa's libGL should be inactive, otherwise you'd be running in software mode.
Since I'm using Debian, my Mesa version is considerably older than yours,
though (4.1). Upgrading my system is pretty much out of the question ATM,
though; I could try installing an up-to-date Mesa from source, but I don't
think that'd work without upgrading the X-stuff as well, which basically
equals a complete system upgrade. I seriously doubt this problem is caused
by GLU anyway; doesn't look like it aborts because of tesselation gone bad
or something...

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list