[Bug 3925] New: ISS runtimes dosen't install

Wine Bugs wine-bugs at winehq.org
Thu Nov 24 06:38:15 CST 2005


           Summary: ISS runtimes dosen't install
           Product: Wine
           Version: 0.9.2.
          Platform: PC
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: wine-msi
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: tuharsky at misbb.sk

Debian Sarge 3.1 Stable, gcc version 3.3.5, no windows installation (wine only).

We use propietary app called ISS, which runs on VFP7 and is transiting to VFP9.
The runtime installer is custom made by vendor. He also uses some lower-level
installation ways that allow us to install the runtimes.

The installation now typically works like this:
1, I run setup.exe, click whatever needed. App ends up with some "installation
interrupted". Runtimes are not functional.
2, I run copy script that copies needed libraries to desired destination
3, I run regedit to register the appropriate .reg file
4, I run setup.exe again, now ends with success

Everything runs.

Such an installation works on 0.9 only, however. Any newer version of wine, the
installation dosen't work: the installer in step 4 shows the same results as in
step 1 and runtimes don't function.

Since we strongly rely on potential developement of wine, we need to be able to
run the current version with all bugfixes available. Thus broken installation
dosen't help either ;o)

I can't tell, what's the difference so I managed to run both installations,
create logs and send in here.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list