[Bug 3515] Picasa can't embed browser window

Wine Bugs wine-bugs at winehq.org
Sun Oct 23 17:46:42 CDT 2005


------- Additional Comments From nelson_menezes at yahoo.co.uk  2005-23-10 17:46 -------
I can confirm this on 20050930; either of those two buttons result in these

err:ole:CoInitializeEx Attempt to change threading model of this apartment from
0xa to 0x2
err:ole:CoGetClassObject class {4955dd33-b159-11d0-8fcf-00aa006bcc59} not registered
fixme:ole:CoCreateInstance no classfactory created for CLSID
{4955dd33-b159-11d0-8fcf-00aa006bcc59}, hres is 0x80040154

... and nothing happens in Picasa (stays operational otherwise), but once it's
closed it tries to open the embedded window (a section of the screen becomes
frozen, as if a window were there), and a security warning comes up ("you have
requested an encrypted page... etc"), as well as a "fatal error" that is only
displayed on the KDE taskbar (no window).

Once the first warning is dimissed, part of the "frozen window" actually loads
up the embedded URL (as if the frozen window were the now-closed Picasa, and the
browser were loading on the main part of its window, leaving space for toolbars
around it), but that whole area of the screen (top left) remains
unclickable/unfocusable until I right-click on the "fatal error" message on the
taskbar and hit "close", which removes the frozen window altogether. This also
triggers the debugger output.

I have Internet Explorer 6.1 installed on Wine, as well as the Mozilla ActiveX
Control v1.7.7 (with required msvcp60.dll file).

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list