[Bug 6345] Every OpenGL application crashes, D3D works just fine

Wine Bugs wine-bugs at winehq.org
Tue Oct 3 17:19:11 CDT 2006


------- Additional Comments From willie at froq.net  2006-03-10 17:19 -------
Thanks a lot for looking into this! I just tried again, clean build, latest 
GIT, with your patch (bug #5959, thanks again!) applied - OpenGL applications 
still crash. Shouldn't be a problem with the OpenGL drivers, because, as I 
said, D3D applications work just fine with Wine, no problems (been playing 
Half Life 2 Ep 1 all night). Native Linux OpenGL applications also work 

The log I attached doesn't help? I don't really understand most of it, but the 
address (0x33fc48) where the exception occurs seems to be OpenGL/ WGL related:

--- 8< ---
0009:trace:opengl:wine_glGetIntegerv (34379, 0x33fc48)
0009:trace:wgl:internal_glGetIntegerv pname: 0x864b, params 0x33fc48
0009:trace:wgl:X11DRV_wglGetIntegerv pname: 0x864b, params: 0x33fc48
0009:trace:seh:raise_exception code=c000001d flags=0 addr=0x33fc48
wine: Unhandled illegal instruction at address 0x33fc48 (thread 0009), 
starting debugger...
--- >8 ---

This is on gentoo/ amd64. I tried Nvidia drivers 1.0.8762 and 1.0.8774 with 
identical results. 

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list