[Bug 2561] Fails to install Garmin mapsource completely

Wine Bugs wine-bugs at winehq.org
Sun Apr 8 02:11:32 CDT 2007


------- Additional Comments From dank at kegel.com  2007-08-04 02:11 -------
Tried again today (hope never dies).
I checked all the region checkboxes, so this time I
really did have to insert both discs.  I now
always use 'wine eject' when switching discs,
as that works better sometimes, and it worked fine.

The app does something different when you start it:
it complains
  There is a problem with the MapSource registry.
  Please re-install MapSource and start it again.
Looking at +reg,+relay it seems to be looking
for Garmin registry keys in HKLM and not finding them.

0009:Call advapi32.RegOpenKeyExA(80000002,001d9561
"Software",00000000,00020019,0034fab8) ret=00419e0d
trace:reg:NtOpenKey <- 0x68
0009:Ret  advapi32.RegOpenKeyExA() retval=00000000 ret=00419e0d
0009:Call advapi32.RegOpenKeyExA(00000068,001d95c1
"Garmin",00000000,00020019,0034fa2c) ret=00419e0d
trace:reg:NtOpenKey <- (nil)
0009:Ret  advapi32.RegOpenKeyExA() retval=00000002 ret=00419e0d

(It already looked for and found Garmin registry keys
in HKCU.)  To confirm, I did
  $ cd ~/.wine
  $ grep -i garmin *.reg
All the matches were in user.reg, none in system.reg.

I haven't checked to see whether those keys exist on Windows.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list