[Bug 8172] New: IL-2 Sturmovik under wine -> mouse not working

Wine Bugs wine-bugs at winehq.org
Wed Apr 25 13:38:29 CDT 2007


           Summary: IL-2 Sturmovik under wine -> mouse not working
           Product: Wine
           Version: 0.9.35.
          Platform: Other
        OS/Version: other
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: wine-directx-dinput
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: bbaeyens at gmail.com

Fresh install of Ubuntu Feisty with wine 0.9.35 (installed through Automatix2).
Tried running IL-2 Sturmovik (1946) under wine, it starts, but the mouse pointer
does not move. The game does respond to key inputs, so its not frozen. Console
shows nothing special.

I tried running the game full screen, windowed, I tried some tricks like alt
tabbing in and out, sending the window to another viewpoint, changing mouse
settings in winecgf nothing cures it. It worked fine with ubuntu Edgy and wine

In case it matters, I use a wireless USB logitech MX Revolution mouse, with no
special configuration or tweaking. The same problem occurs when I connect a
wired Logitech MX500.

It might be interesting to note such mouse behaviour under windows is also a
known issue when IL2 looses focus, and requires one to alt tab in and out of the
game to regain a working mouse pointer. I suspect this problem should be
reproducable on the very old IL2 demo, downloadable here:

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list