[Bug 9325] When pressing DELETE key character ,(comma) is displayed.

Martin Vanek vanek at vsoft.sk
Sun Aug 19 17:12:01 CDT 2007

I checked it in Fedora 7, Mandriva2007, Suse10.2. No matter what type of keyboard is used (PC104,PC105,qwerty,qwerty-bksl) it's always the same.

I have sent a patch to workaround this bug yesterday (edit.c, WM_CHAR notification). VK_DELETE has the same code as comma character 0x2E, but the difference is in lParam - bit 24 specifies whether the key is an extended key. It's not perfect but it works. Better solution of course is to find a basic bug - why is the VK_DELETE sent with WM_CHAR notification to edit control.

I try to run in Linux accounting software (demo program can be downloaded from http://www.vsoft.sk/wdemofib.exe), everything is fine except some minor errors in wine. You need not to run it; wine notepad shows the same error. With US keyboard layout it's ok.

Martin Vanek

Dne Sun, 19 Aug 2007 21:44:52 +0200 <wine-bugs at winehq.org> napsal/-a:

> http://bugs.winehq.org/show_bug.cgi?id=9325
> --- Comment #5 from Mikolaj Zalewski <mikolaj.zalewski at gmail.com>  2007-08-19 14:44:52 ---
> Could you write something more how to recreate the bug? In a Ubuntu 7.04 in
> System > Preferences I changed the keyboard layout to Slovakia > qwerty or
> Slovakia > Extended Backspace, run "wine notepad" (I've even tried "LC_ALL=sk
> wine notepad") and the delete key worked fine.
> In what program do you have a problem? What distribution are you using?

More information about the wine-bugs mailing list