[Bug 7018] Civilization3 doesn't start anymore (GLXBadDrawable)

Wine Bugs wine-bugs at winehq.org
Sat Jan 6 08:39:21 CST 2007


------- Additional Comments From ville.aakko at gmail.com  2007-06-01 08:39 -------

Hi all,

The screenshot I posted above shows the dialog box you'll get if you wont run
LSANS.fot in the background (see the Civilization 3 Conquests appdb entry -
there should really be a separate bug report for this, although there is a
workaround). The problem here I really wanted to point out, is that previously
that dialog box had proper texturing. Maybe that is related with Civilization 3
Conquests not running at all (even with LSANS.fot running in the background)?

I'm running under wine 0.9.28 and Gentoo. If I run LSANS.fot in the background
I'll get the following (again slightly different) output:

fixme:x11drv:X11DRV_desktop_SetCurrentMode Cannot change screen BPP from 32 to 16
err:ole:CoUninitialize Mismatched CoUninitialize
err:ole:CoGetClassObject class {5959df60-2911-11d1-b049-0020af30269a} not registered
err:ole:CoGetClassObject no class object {5959df60-2911-11d1-b049-0020af30269a}
could be created for context 0x1
fixme:win:WIN_CreateWindowEx Parent is HWND_MESSAGE
fixme:font:CreateScalableFontResourceA (0,"LSANS.fot","C:\\Pelit\\Civilization
3\\Conquests\\LSANS.TTF",(null)): stub
 /* ^ The line above is repeated 100-200 times or so ^ */
X Error of failed request:  GLXBadDrawable
  Major opcode of failed request:  128 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  820
  Current serial number in output stream:  820

I'm using the proprietary nvidia drivers (1.0.9631 - the last version that works
on my GeForce4 TI 4800SE). Also, I tried the Civilization 3 demo, but it dies
silently without any output to console.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list