[Bug 8770] New: Warcraft III freezes in BN ladder games after a few seconds/minutes (ATI)

Wine Bugs wine-bugs at winehq.org
Fri Jun 22 12:18:48 CDT 2007


           Summary: Warcraft III freezes in BN ladder games after a few
                    seconds/minutes (ATI)
           Product: Wine
           Version: 0.9.18.
          Platform: PC
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: wine-opengl
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: julas at toya.net.pl

After starting a ladder game on Battle.net (all other types of games work fine),
Warcraft III freezes after a few seconds/minutes. This bug probably appeared in
0.9.18, as I've just managed to play a 29 minute long game on 0.9.17. Wine
versions I tested from http://wine.budgetdedicated.com/archive/index.html (for
0.9.12, 0.9.15, 0.9.16, 0.9.17: no freeze
0.9.18, 0.9.24 and 0.9.39 for Ubuntu 7.04: freeze

After the game freezes, the only thing you can do is login via ssh and killall
-9 war3.exe. It seems that it only affects ATI based cards, no matter what
driver (either Mesa or ATI's fglrx). However, with Mesa driver the game runs for
about 5-15 minutes, while with fglrx for 0-3 minutes (sometimes crashes just
after the loading screen).

I managed to generate four logs with different WINEDEBUG options and put them
here: http://toya.net.pl/~julas/w3-wine/ (should I post them here as well?)
I tried disabling sound, but it still crashes (maybe a few minutes later).
Running wine with aoss removes dsound underruns.

Moreover, there appears a kind of 'hiccup' even under Wine 0.9.17 and older. A
short, maybe 0.5-1 sec., freeze. And I guess the first such freeze appears more
or less at the time when newer versions crash. It usually happens more than once
in a match, which may be annoying, but the game is still playable.

My config (but a few other users with different configs reported this as well):
- Athlon XP 2600+
- nForce2
- 512 MB RAM
- ATI Radeon 9600 Pro
- Ubuntu Feisty 7.04
- Mesa 6.5.2 / fglrx 8.34.8
- Xorg 7.2
- Linux 2.6.20

Warcraft III run by invoking:
[aoss] wine "./Frozen Throne.exe" -opengl

My guess for the component is wine-opengl (or wine-x11driver), as it seems to
occur only with ATI cards.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list