[Bug 7653] GDI deadlock on startup of any program

Wine Bugs wine-bugs at winehq.org
Wed Mar 7 17:45:28 CST 2007


------- Additional Comments From zarquon at t-online.de  2007-07-03 17:45 -------
Leftover stuff is unlikely because I always clean the tree _before_ patching
it up (so I couldn't find any *.o *.a *.so files after a regular clean). OK,
I tried distclean anyway, deleted all leftover Makefiles and configured the
tree. Anything in particular you're interested in? Because the verbose output
doesn't look any different, apart from some messages about specials that won't
be built at the end (like CUPS support or XRandr).
Then I tried running it, but it failed exactly as before. So I renamed ~/.wine
and ran tools/wineprefixcreate -- which built and populated ~/.wine and then

wine: Unhandled page fault on read access to 0x00000037 at address 0x6028bdc0
(thread 0009), starting debugger...
warn:gdi:GDI_GetObjPtr Invalid handle 0xe88
warn:gdi:GDI_GetObjPtr Invalid handle (nil)
wine client error:0: init_thread failed with status c000011f
err:seh:start_debugger Couldn't start debugger ("winedbg --auto 406 820") (1359)
Read the Wine Developers Guide on how to set up winedbg or another debugger
err:seh:raise_exception Unhandled exception code c000013a flags 0 addr 0x601f53c2

I then tried running 0.9.32 with this new ~/.wine and first had to fiddle
around with drive_c and dosdevices/c: a bit because my windows stuff is
located elsewhere (symbolic links), but got that sorted out (including the
updated C:\windows directory). So I tried 0.9.32 on DeusEx and it bombed
too. Noteworthy stuff:

warn:module:load_builtin_dll failed to load .so lib for builtin
/cryptohome/andreas/.wine/dosdevices/c:/Programs/DeusEx/System/Core.dll: invalid
ELF header

This seems a bit odd. Even if it's OK it's highly irritating.

warn:module:load_builtin_dll cannot open .so lib for builtin L"Core.dll":
/opt/wine/lib/wine/core.dll.so: cannot open shared object file: No such file or

This is odd because /opt/wine is my regular install directory (currently
0.9.8) and since I'm running 0.9.32 from the source directory, Wine shouldn't
look there at all!

warn:module:load_builtin_dll failed to load .so lib for builtin
/cryptohome/andreas/.wine/dosdevices/c:/windows/system32/advapi32.dll: invalid
ELF header
wine: Unhandled page fault on read access to 0x00000000 at address 0x602892dd
(thread 0009), starting debugger...
err:seh:raise_exception Unhandled exception code c0000005 flags 0 addr 0xb579c

The end. I'll probably try the full 0.9.32 tarball tomorrow (I used the
patches so far), but highly doubt it'll fix this problem. Any further ideas?

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list