[Bug 7699] New: Crash when application (Stable32) tries to write file

Wine Bugs wine-bugs at winehq.org
Mon Mar 12 18:17:49 CDT 2007


           Summary: Crash when application (Stable32) tries to write file
           Product: Wine
           Version: 0.9.32.
          Platform: PC
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: wine-user
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: jra at febo.com

Dan, I've been playing more with Stable32 under wine.  As I mentioned in
my earlier message, I discovered that if I ran "wine stable32" from
within the Stable32 directory and tried to open a file in the parent
directory (one level up), the error occurred.  If I run from within the
parent directory, it works fine.

That situation continues.  However, I've found another problem that
triggers a hard lockup, rather than a crash.

1.  From ~/.wine/drive_c/Program Files/Hamilton Technical
Services/Stable32 run the program.

2.  Use the file dialog to open PHASE.DAT, selecting the button for
"phase data" rather than the default frequency data.

3.  Use the plot tool to generate a plot.  That will work just fine.

4.  After proving that works, click the "convert" button to create a BMP
output file.  After you go through a couple of steps, you will end up
with silence that seems to indicate success, but at that point the
program is frozen.

5.  If you click the close button in the upper right of the window,
after a few seconds you will get a message that the program isn't

6.  If you select to terminate at that point, the message on the console is:

wine: Unhandled page fault on read access to 0x00222000 at address
0xb7de437c (thread 0010), starting debugger...

I have tried this using Windows 2000 and Windows 98 OS choices, and
running with sudo as well as normally.

We are making progress, but this is still a significant problem.  Any
ideas on what to do next?

By the way -- one other thing I notice, which may or may not be related.
 If, in the file open dialog, you click on "open" without having
selected a file, you get a message to the effect "can't open /home/jra"
(or whatever).  That's fine.  But if you then select a file and try to
open it, the program immediately crashes.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list