[Bug 7708] New: xwall doesn't install

Wine Bugs wine-bugs at winehq.org
Wed Mar 14 02:50:32 CDT 2007


           Summary: xwall doesn't install
           Product: Wine
           Version: CVS
          Platform: Other
               URL: http://xwall.us
        OS/Version: other
            Status: NEW
          Keywords: download, Installer
          Severity: normal
          Priority: P2
         Component: wine-setupapi
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: dank at kegel.com

While googling for something else, I ran into
which is an explanation of how to install xwall (a spam filter server) 
under wine.
It's a scary recipe; it calls for a bazillion native DLLs, including ie6,
installed with winetools.

Trying to run xwall's setup.exe without any of that crap yields a 
fatal dialog
  Installation failed
  usage: setup [mailbeam.inf]

Looking at the log, it seems the installer invokes

0009:Call shell32.ShellExecuteA(00000000,0040700e "install",00407004
"xwall.inf",00000000,00000000,00000001) ret=00401033

i.e. invokes ShellExecute with the verb "install".
Wine seems to do the wrong thing in this case:

0009:Call kernel32.CreateProcessW(00000000,0033de1c

which doesn't seem to work well at all.

Maybe Windows registers a 'install' verb with the shell that knows
what to do with .inf files?  I'm ignorant here.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

More information about the wine-bugs mailing list