[Bug 10282] Issue between WINE, fuse and ntfs-3g

wine-bugs at winehq.org wine-bugs at winehq.org
Mon Nov 5 18:50:02 CST 2007


--- Comment #11 from x patch <jestersi at gmail.com>  2007-11-05 18:50:01 ---
>>> About the crash. How do you exactly mount the partition? By root or by user?
>>> Using mount(8) or ntfs-3g? Is ntfs-3g setuid root? Do you have Wine logs where
>> it crashes?

I usualy let the auto mounter mount the two ntfs partitions I have. 
I mount the partitions as root because only root is allowed to mount by default
in both gentoo and ubuntu ( as far as I know ).

If I mount with the line below then attempt to run say never winter nights 1.
I get the Launcher app that allows me to click Play, Configure etc...
As soon as I click on Play I get a page fault from wine, I will upload the dump

/dev/hda2 /mnt/ntfs2 ntfs-3g users,uid=1000,gid=1000 0 0

If I mount with 
/dev/hda2 /mnt/ntfs2 ntfs-3g rw,uid=1000,gid=1000,nodev,locale=en_CA.UTF-8 0 0

everything is fine and dandy and NWN plays great, same with WoW etc..

>>> Is ntfs-3g setuid root?
I'm unsure how I would check this.

One more note, I develop cross platform opengl/sdl applications the application
I'm currently developing does not seem to care which of the mount params I use.

>>> Here too, there are about a gazillion different scenarios that can lead to a
>>> no-exec page fault. We do have a number of workarounds for it, but depending on
>>> the system configuration they can't always help.

I believe a middle ground solution would be to write a script to check the
sanity of the environment. such as wine-sanity WoW.exe -opengl
find the path that your in check the fstab and check the parameters to see if
there will be potential problems. My knowledge does not extend to mmap and it's
intricacies so unfortunately I don't understand this problem. 

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list