[Bug 10150] New: native dll import broke in 0.9.44 and on

wine-bugs at winehq.org wine-bugs at winehq.org
Tue Oct 23 17:22:48 CDT 2007


           Summary: native dll import broke in 0.9.44 and on
           Product: Wine
           Version: 0.9.44.
          Platform: Other
        OS/Version: other
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: wine-comctl32
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: arno at teigseth.no

wtreader (Watchtower Reader) needs a native comctl32.dll to display a
tooltipbox when hovering the mouse over some link.

This used to work, but something broke from 0.9.43 and on.

Please note, I don't know if it would be correct to assign this to
wine-comctl32, the application is actually using the native comctl32.dll.

Interestingly, running winecfg and setting library comctl32.dll to NATIVE only
in 0.9.43 and earlier will let wtreader run. 

But from 0.9.44 and on, if I set comctl32.dll to native only, a lot of error
messages comes up trying to run the app, saying something like "error importing
dll: comctl32.dll (needed by ...)" and also "error importing dll: commdlg.dll
(needed by ...)"

This makes me think maybe something having to do with calling/importing the
native dll broke from 0.9.44

my 2cents,

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list