[Bug 9758] Libronix Digital Library System - Failure to install

wine-bugs at winehq.org wine-bugs at winehq.org
Wed Sep 26 19:41:20 CDT 2007


--- Comment #3 from Andrew Godfrey <andrew at godfrey.name>  2007-09-26 19:41:19 ---
People are stating that this software 'installs just fine' when in my opinion
it is not installing. For those of you who think this software installs could
you please run the software after installation and test some basic functions -
because I would like to be proved wrong (the path is C:\Program Files\Libronix
DLS\System\LDLS.exe, if you can't find it then keep reading). 

It may be helpful at this point to explain things in more detail based on my
observations over the last week - again happy to be proved wrong. 

Installation of this software is a two part process. You can see this
documented here: http://www.logos.com/support/downloads/ldls/newuser. In
summary the first step is to install a file called DLSSetup.exe. What this does
is install some base files that enable step two to commence. Step two is to run
the following script http://www.logos.com/media/update/30dAutoUpdate.lbxupd
which installs all the files needed to run the program (including the main
executable file LDLS.exe), downloads and installs the various resources you
have purchased, synchronises license files, installs future updates etc. This
update script is essential to install, run and maintain the software, without
it the software is useless.

Various people (including myself) have been posting about this software with
reference to a single zip archive ( documentation here:
http://www.logos.com/support/download/zip, actual file here:
ftp://ftp.logos.com/pub/tech/zip/LibronixDLS-3.0d.zip ). This archive is simply
a way of doing both Step 1 and Step 2 in a single process as well as a download
of everything that the Step 2 script would download for most users. Running the
contents of this zip archive produces the same result as running the individual
files as a two step process mentioned above as they are the same files.

I think this is where the confusion lies. Step 1 (DLSSetup.exe) installs just
fine, however Step 2 (30dAutoUpdate.lbxupd) fails. When running the contents of
the zip archive it completes Step 1 successfully and fails to commence Step 2
without letting the user know that there has been a failure. So when you run
the contents of the zip archive you end up with the exact same result as if you
had run Step 1 only (DLSSetup.exe).

Bug number 9201 has been over this issue already but that bug got closed down
on a technicality (at that stage ies4linux was needed to get Step 1 running and
ies4linux is not supported). The 'update process window' that David Campbell
speaks of is what I call Step 2.

[On a related note Internet Explorer is a stated system requirement. I am not
going to touch this issue with a 40 foot pole as I have no idea about it.
However based on my observation on 0.9.45 it does not matter if you install
ie6setup.exe or use winetricks fakeie6 - the same result is obtained when
installing Step 1 (DLSSetup.exe). I have no idea how this relates to Step 2.]

So where to from here? Should I open a bug about Step 2? This was suggested in
bug 9201 but I cannot find a record in bugzilla of this actually happening. Or
should this bug be re-opened? I would appreciate your advice as to the best way
forward on this. I don't want to open another bug and get closed down on a
technicality (just wastes everyones time).

For myself (and I suspect a lot of people involved in biblical and ancient text
studies) getting this software to work is the only thing stopping me moving to

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list