[Bug 14378] New: Issues with maps and character portrait in Morrowind

wine-bugs at winehq.org wine-bugs at winehq.org
Tue Jul 8 19:24:07 CDT 2008


           Summary: Issues with maps and character portrait in Morrowind
           Product: Wine
           Version: CVS/GIT
          Platform: PC-x86-64
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: directx-d3d
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: mattemod at gmail.com

The patch attached to bug 9775 fixed some issues with Morrowind: the character
portrait (in inventory) is now shown and maps work correctly... but not always.

___With OffscreenRenderingMode="pbuffers"___

Maps work correctly but the character in inventory in upside-down and there's a
red line above it.
It also prints some FIXMEs on the shell when you load a game from a different
location or when you load games saved in outside areas. Also, it doesn't print
those FIXMEs when you load for the first time (in main menu). Here they are:

fixme:d3d_surface:IWineD3DSurfaceImpl_PreLoad >>>>>>>>>>>>>>>>> GL_INVALID_ENUM
(0x500) from glGenTextures @ surface.c / 513
fixme:d3d_surface:IWineD3DSurfaceImpl_PreLoad >>>>>>>>>>>>>>>>> GL_INVALID_ENUM
(0x500) from glBindTexture @ surface.c / 517
fixme:d3d_surface:surface_allocate_surface >>>>>>>>>>>>>>>>> GL_INVALID_ENUM
(0x500) from glTexImage2D @ surface.c / 340
fixme:d3d_surface:read_from_framebuffer_texture >>>>>>>>>>>>>>>>>
GL_INVALID_ENUM (0x500) from glCopyTexSubImage2D @ surface.c / 936

in 'dlls/wined3d/surface.c' at line 509 (after the glEnable() call) the first
FIXME changes with this:

fixme:d3d_surface:IWineD3DSurfaceImpl_PreLoad >>>>>>>>>>>>>>>>> GL_INVALID_ENUM
(0x500) from glEnable @ surface.c / 510

___With OffscreenRenderingMode="fbo"___

The FIXMEs aren't printed at all, the character in inventory is not upside-down
and there's no red line: it works correctly :)

BUT the local map doesn't work at all for me: it's all dark, apart some very
little parts which fade from clear to dark. I'm referring to the local map that
appears right-clicking the mouse, not the one in the bottom-right corner of the
If I'm not wrong, there's only one "faded part" for each area (you can better
see it going outside and scrolling the local map).

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list