[Bug 14762] Max Payne 2: sepia tone filter issues (high PPE)

wine-bugs at winehq.org wine-bugs at winehq.org
Sun Nov 2 12:57:32 CST 2008


--- Comment #9 from Tobias Jakobi <liquid.acid at gmx.net>  2008-11-02 12:57:31 ---
I tried to somehow verify what I suspected to be the issue.

Claim: The issue is due to incorrect texture coordinates. Maybe the ones for
the quad/tris when doing the blit of the processed framebuffer image.
It seems like texture coordinates are supplied in the range [0,1]x[0,1] while
the texture object used is of type RECT and therefore wants them in range

This is due to the lack of hw-accelerated arb_tex_npot support (only
arb_tex_rect is supported without software fallback). Wine doesn't seem to
correct fixup the texcoords.

The following three screenshots "verify" the claim.
1) First shot: Notice the light switch in the upper left corner of the screen.
It has a red area inside.

2) Second shot: Positioning the camera so the most upper-left pixel is a redish
one. I dunno how D3D adresses the screen, but this is possibly what ends up
being pixel with adress (0,0) in the framebuffer.

3) Third shot: Activating fb effect (bullettime / sepia filter). This ends up
producing a screen with redish color flood-fill.

Try with other object with distinct colors. It's always the same.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list