[Bug 16130] New: Runes of Magic client doesn't communicate with the server

wine-bugs at winehq.org wine-bugs at winehq.org
Thu Nov 20 03:14:12 CST 2008


           Summary: Runes of Magic client doesn't communicate with the
           Product: Wine
           Version: 1.1.8
          Platform: PC
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P3
         Component: -unknown
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: ulf at dedio.de

Created an attachment (id=17366)
 --> (http://bugs.winehq.org/attachment.cgi?id=17366)
Wireshark protocol of login on Windows


I tried to start "Runes of Magic" with wine, but failed.

After the installation it starts fine, the License-Dialog and Login-Screen
appear correctly.

After entering the login data, the client tries to communicate with the login
server (authentication and fetching the server list).

This doesn't work with Wine. I attach 2 wireshark protocols. The windows
protocol shows data in the tcp packets from both sides after the SYN.

The Linux/Wine protocol shows data only from the server, the client (running on
Wine) doesn't send data, just an ACK packet.

This leads me to the suspicion, that either the RPC library on Wine is not
working as expected or there is some encryption, which is only done with empty
stubs on Wine.

I tried to substitute rpcrt4.dll and secur32.dll on wine, but it doesn't solve
the problem.

As the Windows rpcrt4.dll leads also to an error (something with service
manager, but after maybe 30sec it continued), I removed it again from the list
of native libs.

If there is some more information, which I can provide, or some test I can do,
please tell me.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list