[Bug 18015] Roller coaster tycoon fails to start

wine-bugs at winehq.org wine-bugs at winehq.org
Sun Apr 19 21:31:30 CDT 2009


Anthony Waters <awaters1 at gmail.com> changed:

           What    |Removed                     |Added
             Status|UNCONFIRMED                 |RESOLVED
         Resolution|                            |INVALID

--- Comment #11 from Anthony Waters <awaters1 at gmail.com>  2009-04-19 21:31:30 ---
ok so I cleared out my ~/.wine directory and added a symlink from 
drive_c/Program Files to the actual directory that contained
RollerCoasterTycoon(RCT)'s files

After doing this the demo ran fine, no errors

so I did WINEDEBUG="+seh,+ddraw,+d3d,+dinput,+loaddll,+relay,+msgbox" 

for both the demo and the full version, turns out the demo tries to load some
stuff from the registry and after that it loads fine.  However, the full
version also tries to load stuff from the registry, but fails because it is not
in there (cleaned out the .wine prefix so the old registry was not there

copied the old register into the .wine prefix and after that running RCT works

Now that I think about it the issue was most likely due to a rogue .dll file
that was compatable with wine-1.1.15, but was broken in wine-1.1.17 and later

thanks for your time

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list