[Bug 18135] 32-bit apps are not supported by 64-bit Wine

wine-bugs at winehq.org wine-bugs at winehq.org
Tue Dec 29 13:52:31 CST 2009


Matthew Turnbull <sparkybluefang at gmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |sparkybluefang at gmail.com

--- Comment #6 from Matthew Turnbull <sparkybluefang at gmail.com>  2009-12-29 13:52:31 ---
(In reply to comment #3)
> The problem is the installer uses a 32-bit wrapper. When wine fully supports
> 64-bit, we'll have to ship a 32bit and 64bit wineserver, then selectively
> choose the appropriate wineserver for the application.

My question is whether those will both be native 64bit applications.

If the solution requires 32bit components, then it's useless to me. I run a
non-multilib version of Gentoo so I can't build 32bit binaries.

Actually, what really interests me is just being able to run Win32 programs in
a 64bit version of Wine. Win64 support has little interest to me, as I don't
use any Win64 programs. I just want to avoid the need for a 32bit chroot laying
around for the occasional Win32 program.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list