[Bug 17830] New: Visual render hang while installing MS Pinball Arcade

wine-bugs at winehq.org wine-bugs at winehq.org
Mon Mar 23 14:14:38 CDT 2009


           Summary: Visual render hang while installing MS Pinball Arcade
           Product: Wine
           Version: 1.0.0
          Platform: PC
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: -unknown
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: vanessaezekowitz at gmail.com

Created an attachment (id=20093)
 --> (http://bugs.winehq.org/attachment.cgi?id=20093)
terminal output from install session (possibly truncated?)

Some time ago, I reported a few bugs regarding Microsoft Pinball Arcade, and
shortly thereafter, my installed copy of the game quit working altogether.  I
was unable to re-install the game for testing possible bug-fixes, as my
original disc was in storage.

I have since retrieved that disc and have found an unusual bug in the way WINE
handles the install.  Steps to reproduce:

1. Pop in the CD, wait for the KDE dialog to pop up.
2. Select "Open in New Window" and minimize the window.
3. Open a terminal and do:  wine "d:\setup.exe"
4. Lots of messages that look like errors will appear on the terminal, and a
new window will open up offering to install the game.
5. Click the large "Install" button.
6. A welcome/confirm screen appears.  Click "Continue".
7. A EULA screen appears.  Click "I Accept".
8. A screen appears asking you where to put the game.  The default is
"C:\Program Files\Microsoft Games\Pinball Arcade".  Click "Continue".
9. A screen appears asking for an installation type.  Click "Complete
10. A progress screen appears and the CD spins up.

Here is where the problem occurs.  Normally, each of the ten markers will drop
in turn, indicating the progress.  What actually happens is that the game
appears to hang and the CD stops, without showing any progress.  Leave it
sitting long enough though, and the CD will spin up again, two markers will
drop from the display, and then the whole thing will jump to a fully installed
state.  However, only two markers will have dropped (all ten should be down by
this point).

Despite that, the game appears to run just fine and behaves as expected.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list