[Bug 10204] Can't create games on D2GS; incorrectly raised FD_WRITE socket event

wine-bugs at winehq.org wine-bugs at winehq.org
Mon Aug 23 02:15:36 CDT 2010


Fredrik <freddalfier at hotmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |freddalfier at hotmail.com

--- Comment #28 from Fredrik <freddalfier at hotmail.com>  2010-08-23 02:15:35 ---
(In reply to comment #27)
> Hi,
> tested with wine 1.3.0 and problem persists.
> I've tried to apply this patch to 1.3.0 and patching failed. I don't know
> why...
> I've tried to replicate the patch by manual editing but it did not work - I
> could not create and join game.
> I have wine from 0.9.x line patched and it works with my current client setup.
> Maintaining wine 0.9.x on the server is a pain, it won't even compile now.
> Is there a patch, which is known to succeed and work with wine 1.3.0?
> Thanks.
> Oleg

Hi Oleg,

it seems sock.c is completely rewritten for 1.3.0 and i can no longer see where
this patch would be applied. However there is a patch from some package
maintainer in the Archlinux user repository that I have used on the "Stable"
version 1.2, and it works just fine.

Download d2gs.patch from: http://aur.archlinux.org/packages.php?ID=34644

Hope it will work for you...

/ Fredrik

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list