[Bug 21717] New: C4 demo fails on startup due to missing XAudio2?

wine-bugs at winehq.org wine-bugs at winehq.org
Sun Feb 14 02:17:34 CST 2010


           Summary: C4 demo fails on startup due to missing XAudio2?
           Product: Wine
           Version: 1.1.38
          Platform: x86
               URL: http://www.terathon.com/c4engine/download.php
        OS/Version: Linux
            Status: NEW
          Keywords: download
          Severity: normal
          Priority: P2
         Component: -unknown
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: dank at kegel.com

I tried downloading the C4 demo,
190214c5cb8b7952583932860147ff287357ce46  C4Demo1.5.9.zip
and running C4. It dies fairly quickly with
err:ole:CoGetClassObject class {03219e78-5bc3-44d1-b92e-f63d89cc6526} not
and a dialog box saying no audio could be found.
A quick search shows that UUID is associated with XAudio2.
"sh winetricks directx9-beta" worked around that.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list