[Bug 15894] postgresql fails to install

wine-bugs at winehq.org wine-bugs at winehq.org
Tue Jan 26 19:46:19 CST 2010


Alexander Scott-Johns <alexander.scott.johns+winebug at googlemail.com> changed:

           What    |Removed                     |Added
                 CC|                            |alexander.scott.johns+wineb
                   |                            |ug at googlemail.com

--- Comment #2 from Alexander Scott-Johns <alexander.scott.johns+winebug at googlemail.com>  2010-01-26 19:46:19 ---
Bug still present with postgresql-8.3.9-1.zip [1] and wine-1.1.37-103-g356b06f.

I was able to progress a bit by directly running the internal installer:
$ wine msiexec /i postgresql-8.3-int.msi INTERNALLAUNCH=1 INSTALLLANG=en

If I uncheck "Install as a service" on the "Service configuration" page, the
installation starts, then stops with a "Fatal error" - "Installation ended
prematurely because of an error:" message (I assume something is meant to
appear after the ':').

If I leave "Install as a service" checked, the installer allows me to create a
new user (not sure if this worked), then displays another error: "Service
check" - "Failed to open the Secondary Logon service: Service does not exist".
After I manage to get past this error, I then get the "Fatal error", as before.

After the installation aborts (in both cases), I have some rather odd
behaviour. Any attempt to run Wine displayed a postgres error message in the

 pg_ctl: no operation specified
 Try "pg_ctl --help" for more information

I have to do a wineserver -k and rm -rf $WINEPREFIX/drive_c/Program\
Files/PostgreSQL/8.3 to get Wine into a sane state again.


Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list