[Bug 23040] New: USB Gamepad not working

wine-bugs at winehq.org wine-bugs at winehq.org
Sat Jun 5 02:52:17 CDT 2010


           Summary: USB Gamepad not working
           Product: Wine
           Version: 1.2-rc2
          Platform: x86-64
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: directx-dinput
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: atomkarinca at gmail.com

I have two USB gamepads and I get the same error output from both. I am trying
to run PES 2010 with gamepad enabled. When I run the game with

WINEDEBUG=+joystick wine pes2010.exe

I get the following lines:

trace:joystick:JSTCK_GetDevCaps Driver: 0x020100, Name: USB Gamepad , #Axes: 6,
#Buttons: 10
warn:joystick:JSTCK_GetDevCaps Unknown axis 40(5). Skipped.

So, as I understand the gamepad is recognized but somehow an axis is preventing
me to use it. I tried to recalibrate the gamepad with jscal but to no avail. I
also tried adding a registry value to HKCU\Software\Wine\DirectInput but yet
again no improvement.

Any idea on how I can get this unknown axis to be recognized?

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list