[Bug 23202] New: Cyberboard Player has missing disabled icons on menubar

wine-bugs at winehq.org wine-bugs at winehq.org
Tue Jun 15 14:27:08 CDT 2010


           Summary: Cyberboard Player has missing disabled icons on
           Product: Wine
           Version: 1.2-rc1
          Platform: x86
               URL: http://cyberboard.brainiac.com/cyberboardv310.exe
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: comctl32
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: wylda at volny.cz
                CC: julliard at winehq.org

Created an attachment (id=28870)
 --> (http://bugs.winehq.org/attachment.cgi?id=28870)
Screenshot showing the problem

During retest of fixed things, i discover this new regression. Cyberbord player
has missing icons in the menu. To reproduce: just download, install to some dir
and run "wine CBPlay.exe".

1. I did a regression test between 1.1.44 and 1.2-rc1:

commit f02adf3e2b3efc23f62c38b9c8f43f169888434f
Author: Alexandre Julliard <julliard at winehq.org>
Date:   Fri May 14 13:38:54 2010 +0200

    comctl32: Generate an alpha channel if necessary when adding images to a
32-bit imagelist.

:040000 040000 5c1aa4b7a9f1b58ed31884baa948b5358a208680
b1776ce23963f7b44c81c494cd54b3bc9302e3c2 M      dlls

2. No other bug report suffers from this commit.

3. Revert of this patch after git checkout makes that problem go away. (can't
revert even on 1.2-rc1)

--private keyword: bisected

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list