[Bug 22203] New: X Error of failed request: BadWindow

wine-bugs at winehq.org wine-bugs at winehq.org
Mon Mar 29 10:38:28 CDT 2010


           Summary: X Error of failed request:  BadWindow
           Product: Wine
           Version: 1.1.31
          Platform: x86
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: -unknown
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: jb.imm at gmx.de

Created an attachment (id=27094)
 --> (http://bugs.winehq.org/attachment.cgi?id=27094)
Crash when it actually starts up

When I want to install an appliation, it shows the spash screen of the
installer, then crashes with the message:

X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  19 (X_DeleteProperty)
  Resource id in failed request:  0x4e00005
  Serial number of failed request:  979
  Current serial number in output stream:  1030

I'm on 32 bit Linux (no 64 bit drivers!) on a 64-bit machine and do have a
Radeon video card (no nvidia module or anythign like that). Using the Ubuntu
wine-1.2 package.

The weird thing is that it usually (19 in 20 times) crashes with that exact
message, but 1 in 20 times it starts up the installer and crashes during the
installation process. I've created an attachment for the message that appears
when it crashes during installation.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list