[Bug 22662] Red Alert 3 1.12 fails to start

wine-bugs at winehq.org wine-bugs at winehq.org
Fri May 14 01:51:17 CDT 2010


--- Comment #16 from The Source <thesource at mail.ru>  2010-05-14 01:51:16 ---
Created an attachment (id=27947)
 --> (http://bugs.winehq.org/attachment.cgi?id=27947)
Visual C++ 2005 SP1 redist setup log

I did install the game with wine, but to make sure I started the whole process
1. Deleted ~/.wine
2. Ran winecfg (which installed gecko in the process, I checked, gecko really
was in place), configured sound, drives etc.
3. Ran regedit to set some d3d flags (like VideoMemorySize)
4. Downloaded Visual C++ 2005 SP1 redist from microsoft site. Installed it
(just in case I attached wine output on the setup because it looks suspicious).
5. Inserted RA3 dvd into dvd drive
6. Ran wine AutoRun.exe on it. Pressed install button on the dialog, setup
requested cdkey, I entered it.
7. Then the program tried to launch EASetup.exe but I got this:
fixme:msi:MSI_OpenDatabaseW open failed r = 8003001e for
Launching EASetup.exe manually results in the same.

As you can see I attempted crystally clean install and installed vcredist2005
as you recommended, but stumbled on non-working game setup in the end.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list