[Bug 13200] Microsoft Pinball Arcade missing some color depth

wine-bugs at winehq.org wine-bugs at winehq.org
Wed May 19 18:04:45 CDT 2010


--- Comment #13 from Vanessa Ezekowitz <vanessaezekowitz at gmail.com>  2010-05-19 18:04:45 ---
Recent versions of WINE have had many troubles with this game.  Anything over
1.1.25 does one of the following, depending on which version we tried (always
with the same build settings, and always displayed on a second X session with
an 8bpp "StaticColor" visual):  

* Crashes WINE outright at game start
* Crashes WINE when you pull the plunger back to launch a ball
* Displays a black screen (on the 8bpp visual that is)
* Displays the game screen but with garbled colors
* Causes the game to exit back to the table select menu when the table is
finished, instead of asking for another quarter as usual.

We probably should have made up some kind of version-vs-problem log, but as I
recall, 1.1.26 and several versions newer had the problem with the
quarter/end-of-table, while 1.1.44 displayed garbled colors.

At any rate, we've masked it back to 1.1.25, which is the highest numbered
version we've found that shows none of the above issues; it is the most recent
one which is fully usable with this particular game.

That aside, every version higher than that which *did* display a non-black,
non-garbled screen still showed the apparent 7bpp depth.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list