[Bug 22923] New: "Cannot read access control list.Error code: 1400" with Tap'Touche Installer

wine-bugs at winehq.org wine-bugs at winehq.org
Sat May 29 03:39:45 CDT 2010


           Summary: "Cannot read access control list.Error code: 1400"
                    with Tap'Touche Installer
           Product: Wine
           Version: unspecified
          Platform: x86
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P5
         Component: advapi32
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: cerebro.alexiel at gmail.com


When I try to install this software, I got the "Cannot read access control
list.Error code: 1400" message while installing it.

After clicking ok 2 or 3 times, the setup goes on and ends without any other
Moreover, the software works perfectly in wine so I'm just reporting this bug
(P5) to just see if someone could fix it.

Here is the interesting part of the WINEDEBUG=+relay log
0027:Call shlwapi.wvnsprintfA(0064df5c,00000400,1000241c "Adjusting %s
permissions for %s",0064e368) ret=100010a6
0027:Ret  shlwapi.wvnsprintfA() retval=00000046 ret=100010a6
0027:Call user32.SetWindowTextA(00000000,0064df5c "Adjusting directory
permissions for C:\\Program Files\\Tap'Touche 5\\Jeux") ret=100010b9
0027:Ret  user32.SetWindowTextA() retval=00000000 ret=100010b9
0027:Call advapi32.GetNamedSecurityInfoA(0064e3bc "C:\\Program
0027:Ret  advapi32.GetNamedSecurityInfoA() retval=00000057 ret=100013c8
0027:Call KERNEL32.GetLastError() ret=100013d2
0027:Ret  KERNEL32.GetLastError() retval=00000578 ret=100013d2
0027:Call shlwapi.wvnsprintfA(0064df54,00000400,100023e8 "Cannot read access
control list.\r\nError code: %d",0064e36c) ret=100010dc
0027:Ret  shlwapi.wvnsprintfA() retval=00000032 ret=100010dc
0027:Call user32.MessageBoxA(00020020,0064df54 "Cannot read access control
list.\r\nError code: 1400",00000000,00040010) ret=100010f6
0009:Call window proc 0x6861ae52

The last parameter of GetNamedSecurityInfoA is NULL and it fails on most
Windows exactly as wine do.
(see https://testbot.winehq.org/JobDetails.pl?Key=2386
-559038737 is DEADBEEF, I'm quite new with these testing stuff)

However, On my virtual XP, it works (no error).
If anyone has an idea...

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list