[Bug 21163] NFS4: Fails to start if Hardware Acceleration is enabled

wine-bugs at winehq.org wine-bugs at winehq.org
Mon Nov 29 02:16:52 CST 2010


--- Comment #21 from Alexey Loukianov <mooroon2 at mail.ru> 2010-11-29 02:16:52 CST ---
(In reply to comment #20)
> It works fine for me. In fact I use DirectX9.0b renderer. Maybe it's up to
> graphic card. Mine is NVIDIA 9xxx and driver is 260.19.21
Got pretty the same GPU hardware - nVIDIA GTS250 (which is essentially same as
9800), but an older version of driver - 256.29. Would try to update and check
if that helps.

> > To the bottom line: the game refuses to work in case the DirectDrawRenderer key
> > exists in the registry with the value set to either "gdi" or "opengl", but
> > start up OK in case there's no such key or the value of the key is invalid
> > (i.e. is not "gdi" nor "opengl").
> I didn't play with these settings because everything was fine.

Sure. Still it'd be good if you find a minute and test this registry key to
cause problems on your PC too. My intention is that if the docs (official wiki)
say that the default in case of absence of this key is "gdi" then the game (and
wine) should work the same with this key present and set to "gdi" and with this
key absent. As this is not true as my test shown then it might be a wrong docs
or a bug in wine.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list