[Bug 19202] eve online 100% cpu usage (frame rate limiter is not limiting anything)

wine-bugs at winehq.org wine-bugs at winehq.org
Sun Oct 10 07:31:03 CDT 2010


--- Comment #35 from Renaud Chaput <renchap at gmail.com> 2010-10-10 07:31:02 CDT ---
(In reply to comment #34)
> Have you tried again in latest wine (1.2rc7)? My system is not as powerful, but
> nevertheless I can't get the fps over the screen refresh. Also check that
> glxinfo says you have GLX_SGI_swap_control support, which I believe is
> responsible for vsync.

Still happening with Wine 1.3.4.
I get about 70 FPS all the time, and the Eve process takes 100% of one CPU
core, event if doing nothing.
I changed config recently, from Athlon 64 X2 to Intel L3426, so i now have 8
cores, but each Eve client still uses one core at 100%. Graphic card is a
Nvidia 460, and GLX_SGI_swap_control is supported (from glxinfo).

It is common in Eve to have more than 2 clients running, and with each one
taking 1 core, you cant launch more clients than cores on your computer without

On Windows, each client does not uses 100% of a core, so this problem is not
present. On the Mac version, which uses CrossOver, the bug is also here.

This bug can easily reproducted by downloading the Eve client
(http://www.eveonline.com/download/), installing it, and launching the game
(idling at login screen takes 100% of one core too).

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list