[Bug 18511] Full Tilt Poker loses sound after a minute

wine-bugs at winehq.org wine-bugs at winehq.org
Sun Sep 12 21:18:08 CDT 2010


--- Comment #9 from Raymond <superquad.vortex2 at gmail.com> 2010-09-12 21:18:08 CDT ---
(In reply to comment #6)
> (The above backtrace is mine, I wrote a message and attached it, but apparently
> this bug tracker eats your comment when you attach a file.)
> I'm running Wine 1.1.42 on Ubuntu 10.04 amd64 on a 4-core machine.  I get a
> crash within 1-10 minutes of joining a table when using ALSA.
> It is easy to work around by choosing OSS in winecfg.
> But it is actually Wine code that is crashing (divide by zero in
> ALSA_AddRingMessage()+0x36), so I thought it would be best to report it here.
> It's probably a very easy bug to fix if you're a Wine dev familiar with the
> architecture of Wine and ALSA.  (Alas, that is not me.)  Simply inspect the
> code of ALSA_AddRingMessage, if you're dividing something in the first dozen or
> so lines, add code to check if the divisor is zero and handle appropriately. 
> Since Full Tilt lets you play for free, you can even download the game yourself
> to reproduce the behavior and test the patch.



without knowing which alsa sound card driver  , it is hard to debug

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list