[Bug 26984] New: Very poor audio (resample?) quality

wine-bugs at winehq.org wine-bugs at winehq.org
Sat Apr 30 14:16:21 CDT 2011


           Summary: Very poor audio (resample?) quality
           Product: Wine
           Version: 1.3.19
          Platform: All
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: -unknown
        AssignedTo: wine-bugs at winehq.org
        ReportedBy: lorefice2 at libero.it

Created an attachment (id=34409)
 --> (http://bugs.winehq.org/attachment.cgi?id=34409)
Audio sample that becomes extremely aliased with wine

As wine 1.3.19 dropped old oss support (now ossv4 only), i'm forced to use alsa
or jack output.
Unfortunately i noticed that if the played sample doesn't match the samplerate
that the user set in wine, audio quality is very (too much) low.

I'm attaching a simple mp3 which clearly exposes the issue.

To reproduce:
download the attached mp3
run winecfg and set it to use alsa
... set acceleration to emulation
... set sample rate to 44khz
download and install winamp
make sure winamp uses directsound iutput driver
play that sample with winamp, hear the good quality.

close winamp
launch winecfg again
... set sample rate to 48khz
play again with winamp and hear the bad quality,sound is full of aliasing
Do the same with jack.

Configure bugmail: http://bugs.winehq.org/userprefs.cgi?tab=email
Do not reply to this email, post in Bugzilla using the
above URL to reply.
------- You are receiving this mail because: -------
You are watching all bug changes.

More information about the wine-bugs mailing list